You can read these without choosing:

Tallybuy
Deliver toDE

Zyxel

Zyxel GS1900-24EP Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black

1 offer · 1 shop · last checked 2026-10-29 20:18 (Europe/Berlin)

Switch type
Managed
Switch layer
L2
Basic switching RJ-45 Ethernet ports quantity
24
Power connector
AC-in jack
Product image: Zyxel GS1900-24EP Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) Black1 / 5

Delivered total

EUR 261,85

Sold by 0815 DE · GS1900-24EP-EU0101F · New

Offers

1 live offer

Ordered by delivered total, lowest first. Offers whose total is not stated follow; that placement says nothing about their price.

Links to merchants are affiliate links (advertising). Tallybuy earns a commission if you buy. The offers, their order and what you pay stay the same. About affiliate links

Observed item prices

0815 DE, one listing

This is the item price of one seller's listing, not a delivered total and not the best price across sellers.

Observed prices over time

Latest
EUR261,8529 Oct 2026
Lowest
EUR246,499 Oct 2026
Highest
EUR261,8512 Oct 2026
Observed prices over time
DayLowestHighestLastChecks
29 Oct 2026EUR261,85EUR261,85EUR261,853
28 Oct 2026EUR261,85EUR261,85EUR261,853
27 Oct 2026EUR261,85EUR261,85EUR261,853
26 Oct 2026EUR261,85EUR261,85EUR261,852
25 Oct 2026EUR261,85EUR261,85EUR261,853
24 Oct 2026EUR261,85EUR261,85EUR261,853
23 Oct 2026EUR261,85EUR261,85EUR261,851
22 Oct 2026EUR261,85EUR261,85EUR261,853
21 Oct 2026EUR261,85EUR261,85EUR261,853
20 Oct 2026EUR261,85EUR261,85EUR261,853
19 Oct 2026EUR261,85EUR261,85EUR261,852
18 Oct 2026EUR261,85EUR261,85EUR261,853
17 Oct 2026EUR261,85EUR261,85EUR261,853
16 Oct 2026EUR261,85EUR261,85EUR261,853
15 Oct 2026EUR261,85EUR261,85EUR261,853
14 Oct 2026EUR261,85EUR261,85EUR261,853
13 Oct 2026EUR261,85EUR261,85EUR261,853
12 Oct 2026EUR246,49EUR261,85EUR261,853
11 Oct 2026EUR246,49EUR246,49EUR246,493
10 Oct 2026EUR246,49EUR246,49EUR246,491
9 Oct 2026EUR246,49EUR246,49EUR246,493

About this product

Zyxel GS1900-24EP, Managed, L2, Gigabit Ethernet (10/100/1000), Full duplex, Power over Ethernet (PoE), Rack mounting

Read the full source description

Near silent operation The GS1900 Series includes both fan-less and built-in smart fan models. The smart fan is designed to automatically adjust speed based on device temperature. You can barely hear the sound while the switch is operating. It is ideal for your office environment.

Intelligent PoE+ powers more devices PoE models (8HP/10HP/24EP/24HPv2/48HPv2) come with default PoE consumption mode which delivers only the actual power required by your networked devices, reserves the rest and optimizes its power budget. That means a single switch can power more APs, IP cameras and VoIP phones, ensuring a better ROI for your business. All of them support the IEEE 802.3at providing a maximum of 30W per port.

Speedy Gigabit performance—built for SMBs The GS1900 is a series of switches with full non-blocking bandwidth of up to 1 Gbps per port. An ideal upgrade from an unmanaged switch, it’s a great choice for SMBs that want to enjoy high-speed business network applications at full wired non-blocking speed.

Easy and intuitive management The Smart Managed GS1900 Series switch feature with web-based interface to manage advanced functions such as VLAN, QoS, IGMP Snooping, Link Aggregation (LAG), IPv6 and DoS prevention easily. Also, the user-friendly wizard helps to walk through setup, configuration and even advanced settings quickly.

Text from Specs Icecat.

Specifications

56 specifications

Product data: Specs Icecat

GTIN
04718937609468
MPN
GS1900-24EP-EU0101F
Management features4
Switch type
Managed
Switch layer
L2
Quality of Service (QoS) support
Yes
MIB support
RFC 1213 MIB II RFC 2819 RMON (group 1, 2, 3, 9) RFC 1215 generic traps RFC 1493 bridge Zyxel private common MIB
Ports & interfaces3
Basic switching RJ-45 Ethernet ports quantity
24
Basic switching RJ-45 Ethernet ports type
Gigabit Ethernet (10/100/1000)
Power connector
AC-in jack
Network13
Networking standards
IEEE 802.1D, IEEE 802.1ab, IEEE 802.1af, IEEE 802.1s, IEEE 802.1w, IEEE 802.3at, IEEE 802.3az, IEEE 802.3p, IEEE 802.3u, IEEE 802.3x
10G support
No
Cable types supported
Cat5, Cat5e
Port mirroring
Yes
Full duplex
Yes
Flow control support
Yes
Link aggregation
Yes
Auto MDI/MDI-X
Yes
Spanning tree protocol
No
Ethernet LAN data rates
10,100,1000 Mbit/s
MAC address auto-learning supported
Yes
VLAN support
Yes
Virtual LAN features
Tagged VLAN, VLAN Identifier ( VLAN ID), Voice VLAN
Data transmission7
Switching capacity
48 Gbit/s
Forwarding rate
35.7 Mpps
MAC address table
8000 entries
Store-and-forward
Yes
Jumbo frames support
Yes
Jumbo frames
9000
Packet buffer memory
0.525 MB
Security8
DHCP features
DHCP client
IGMP snooping
Yes
Security algorithms
802.1x RADIUS
MAC address filtering
Yes
Static port security
Yes
SSH/SSL support
Yes
Password protection
Yes
Authentication type
HWTACACS+, IEEE 802.1x, RADIUS
Multicast features1
Multicast support
Yes
Design4
Rack mounting
Yes
Stackable
Yes
Product colour
Black
Reset button
Yes
Performance1
Noise level
26 dB
Power4
Power supply included
Yes
AC input voltage
100 - 240 V
AC input frequency
50 - 60 Hz
Power consumption (typical)
206.5 W
Power over Ethernet (PoE)1
Power over Ethernet (PoE)
Yes
Weight & dimensions4
Width
330 mm
Depth
330 mm
Height
44 mm
Weight
2.48 kg
Packaging content4
Cables included
AC
Quick start guide
Yes
User guide
Yes
Manual
Yes
Packaging data1
Package type
Box
Logistics data1
Harmonized System (HS) code
85176990